Back to overview
Update
Aug 27 at 10:56pm BST
Affected services
Harvest Media Admin
Public API
Downloads
Assets
Flex
PRO3
Amplify
Resolved
Aug 27 at 10:56pm BST
Process of recovery on services are continuing and we anticipate service restoration in the next 15 minutes. Another update will be posted in 15 minutes. Thank you for your patience.
Affected services