Back to overview
Degraded

We are currently reviewing intermittent slowness across our services

Sep 10 at 03:45pm BST
Affected services
Harvest Media Admin
Public API
Downloads
Assets
Flex
PRO3
Amplify

Resolved
Sep 10 at 04:21pm BST

Services were restored some 20minutes ago however our team is working to understand the root cause of slowness and intermittent failures that occurred. This update is being marked as solved.

Updated
Sep 10 at 04:17pm BST

Resolved

Updated
Sep 10 at 04:01pm BST

We are continuing to monitor this incident, whilst services are operational we are working to understand the root cause of this slowness and service degradation.

Created
Sep 10 at 03:45pm BST

We are receiving alerts on our services and our team are investigating the underlying cause currently.

We will post a follow up update in 15 minutes.