Back to overview
Degraded

Download failures

Sep 15 at 10:52am BST
Affected services
Harvest Media Admin
Public API
Downloads
Assets
Flex
PRO3
Amplify

Resolved
Sep 15 at 11:16am BST

Services are restored

Created
Sep 15 at 10:52am BST

We are currently investigating timeouts for downloads. We are actively reviewing the issue and will provide an update here within 15 minutes.